Reply
Visitor
Posts: 2
Registered: 2 weeks ago
0

Problem with commas

Hi,

 

I was hoping someone here could help me,

 

I use an edited version of the MHRA style:

Author, Title| , trans. Translator|, Edition |(|Place Published|: Publisher|, Year|)|.

 

However, when there is no translator and edition, or just the translator (but not just the edition!), I get a comma after the title:

Leary, T., The Politics of Ecstasy, (Berkeley: Ronin, 1990).

When I would like it to look like this:

Leary, T., The Politics of Ecstasy (Berkeley: Ronin, 1990).

 

I am really struggling to change this. HELP!

 

Mentor
Posts: 2,068
Registered: ‎09-30-2009
0

Re: Problem with commas

[ Edited ]

Your bibliography template is likely missing the “Link Adjacent Text” command in several places. The Link Adjacent Text command “joins” two or more items together so they act as one unit. In your case, it will link the comma if: 1) there is a translator; and/or 2) if there is an edition. No comma will be generated if there is no translator or edition.

 

Suggest you insert the Link Adjacent Text command (noted as an asterick in the example) in the bibliography template as shown below. Note that no spaces occur between the comma and field name.

 

Author, Title|,*trans.*Translator|,*Edition |(|Place Published|: Publisher|, Year|)|.

 

Mentor
Posts: 7,224
Registered: ‎04-10-2008
0

Re: Problem with commas

If you still have problems, add the modified output style and we can tweak it for you. My version is attached, in the book template, so you could open it and paste it into your template. 

(long time Endnote user)
Highlighted
Visitor
Posts: 2
Registered: 2 weeks ago
0

Re: Problem with commas