Reply
User
Posts: 8
Registered: ‎07-14-2016
0

Control publication date IMF

Hello all.

I am not able to get the pubmed filter to control the date of publication field as desired.

The tag line looks like:

DP  - 2015 Mar

The import filter has:

DP - Year
DP - Year Date

This results in the year in the Year field and the month in the Date field. Not what I want. I want just the year in the Year field.

I tried:

DP - Year {IGNORE}
DP - Year Date

This ends up importing nothing. I don't understand.

Can someone please help?

Thanks much, respectfully,

IMF

User
Posts: 8
Registered: ‎07-14-2016
0

Re: Control publication date IMF

Hi again.

Actually what I really want is the year in the Year field and the entire year and month in the Date field.

Thanks,

IMF

Mentor
Posts: 2,075
Registered: ‎09-30-2009
0

Re: Control publication date IMF

[ Edited ]

The year and month is stored in the same DP-tagged field with just a blank space (and no delimiter/punctuation) separating the two pieces of information. This makes it difficult to parse each piece into a separate Endnote field (Year, Date).

As a workaround you could:

 

  1. Modify the import filter so the tagged field includes Year and Date [DP - Year Date] and either delete or ignore the second DP field. (Refer to image #1 which shows the imported result.)

  2. After importing the references, select them then use Endnote’s Copy Fields* function to copy the Year field into the Date field so the result displays the year and month. *Go to the Endnote toolbar and select Tools >Change/Move/Copy Fields. (Refer to image #2 which shows the Copy Fields setting and the result.)
User
Posts: 8
Registered: ‎07-14-2016
0

Re: Control publication date IMF

Thanks all. I will try this.

I still don't understand why

 

year {IGNORE}

 

imports nothing. Anybody know?

Thanks,

IMF

Mentor
Posts: 2,075
Registered: ‎09-30-2009
0

Re: Control publication date IMF

Endnote’s [IGNORE] command forces the program to ignore importing pieces of unwanted information. In your case, the import tag and data field DP - Year {IGNORE} instructs Endnote to ignore importing data into the Year field which is why nothing is imported.